Proxy BCAAA error 'A device attached to the system is not functioning' and not seeing all users on IWA browse on VPM
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Proxy BCAAA error 'A device attached to the system is not functioning' and not seeing all users on IWA browse on VPM

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Article ID: 235409

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Updated On:

Products

SG-S200

Issue/Introduction

ProxySG is configured to use IWA-BCAAA authentication
BCAAA Agent is not able to send Users or Groups to the ProxySG

 

1. When doing an IWA browse for the realm on VPM, the following error is seen

- A device attached to the system is not functioning, Windows reporter error during search

- Receive error on socket search

 


2. In the BCAAA debug, the following error is seen

Admin services unexpected error.; status=31:0x1f:A device attached to the system is not functioning.

Refer https://knowledge.broadcom.com/external/article/166076/gather-bcaaa-debug-logs.html on the procedure to run BCAAA debug


3.In the wireshark packet captures on BCAAA server, the domain controller returns a STATUS_PENDING error

Environment

Release :BCAAA Agent version: 6.1.52

Component :Windows Server 2019 Server Standard Full Installation 64-bit

Cause

1. The below document explains details of this error

0x00000103 STATUS_PENDING -The operation that was requested is pending completion.

https://docs.microsoft.com/en-us/openspecs/windows_protocols/ms-erref/596a1078-e883-4972-9bbc-49e60bebca55

2. This is not an issue with the Auth connector (BCAAA agent), but rather a known issue with Microsoft's patch updates listed below.  Please refer to each KB links below for further details regarding the known issue. In each KB link below, there is a section titled "Known issues in these updates". In this section, Microsoft mentions a known issue with the NetQueryDisplayInformation API that may fail to return results after the first page of data often 50 – 100 entries.

3.This is a known issue that Microsoft has reported in the following updates and states they are working on a fix in the workaround section.

Resolution

This issue was resolved in KB4520062

https://support.microsoft.com/en-us/topic/october-15-2019-kb4520062-os-build-17763-832-9c68cbd5-01f8-fb1b-d168-d6c4c197098c

Refer Addressed issues-:
Addresses an issue with applications and scripts that call the NetQueryDisplayInformation API or the WinNT provider equivalent. They may fail to return results after the first page of data, often 50 or 100 entries. When requesting additional pages, you may receive the error, “1359: an internal error occurred.”

For more details on the recommended patch, please contact Microsoft