Proxy BCAAA error 'A device attached to the system is not functioning' and not seeing all users on IWA browse on VPM
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Proxy BCAAA error 'A device attached to the system is not functioning' and not seeing all users on IWA browse on VPM

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Article ID: 235409

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Updated On:

Products

ProxySG Software - SGOS

Issue/Introduction

ProxySG is configured to use IWA-BCAAA authentication
BCAAA Agent is not able to send Users or Groups to the ProxySG

 

1. When doing an IWA browse for the realm on VPM, the following error is seen

- A device attached to the system is not functioning, Windows reporter error during search

- Receive error on socket search

 


2. In the BCAAA debug, the following error is seen

Admin services unexpected error.; status=31:0x1f:A device attached to the system is not functioning.

Refer https://knowledge.broadcom.com/external/article/166076/gather-bcaaa-debug-logs.html on the procedure to run BCAAA debug


3.In the wireshark packet captures on BCAAA server, the domain controller returns a STATUS_PENDING error

Environment

Release :BCAAA Agent version: 6.1.52

Component :Windows Server 2019 Server Standard Full Installation 64-bit

Cause

1. Meaning of the error

0x00000103 STATUS_PENDING -The operation that was requested is pending completion.

2. This is not an issue with the Auth connector (BCAAA agent), but rather a known issue with Microsoft's patch updates listed below.  Please refer to each KB links below for further details regarding the known issue. In each KB link below, there is a section titled "Known issues in these updates". In this section, Microsoft mentions a known issue with the NetQueryDisplayInformation API that may fail to return results after the first page of data often 50 – 100 entries.

3.This is a known issue that Microsoft has reported in the following updates

August 17, 2019—KB4512495 (OS Build 14393.3181)
August 13, 2019—KB4512517 (OS Build 14393.3144)
July 16, 2019—KB4507459 (OS Build 14393.3115)
July 9, 2019—KB4507460 (OS Build 14393.3085)
June 27, 2019—KB4509475 (OS Build 14393.3056)
June 18, 2019—KB4503294 (OS Build 14393.3053)
September 10, 2019—KB4512578 (OS Build 17763.737)

Resolution

This issue was resolved in KB4520062

October 15, 2019 - KB4520062 (OS Build 17763.832)

For more details on the recommended patch, please contact Microsoft