Does Data Aggregator Change Detection update entries like sysLocation?
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Does Data Aggregator Change Detection update entries like sysLocation?

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Article ID: 235102

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Updated On:

Products

DX NetOps CA Performance Management - Usage and Administration

Issue/Introduction

Does change detection update entries like location or is that accomplished only with a rediscovery?

How do we update device level information for Performance Management discovered devices?

When does Performance Management update hrSystem MIB table OID values like sysDescr, sysContact, sysName, sysLocation, etc?

Host Resources table OIDs in question

Environment

All supported DX NetOps Performance Management releases

Cause

Values on the device have changed but the changes are not seen in the Performance Management UI.

Resolution

These values are updated during Change Detection (CD) cycles using the System Information OOTB Monitoring Profile.

That MP is assigned to all SNMP Managed devices. It runs on a 168 hour (7 days) schedule.

Devices could be updated anywhere from 1 to 7 days after the changes are made to the relevant MIB OIDs.

Ways to work around the default configuration:

  1. Change the schedule of the default System Information Monitoring Profile. This  would require the following steps.
    1. Create a custom copy of the Monitoring Profile. Set a custom name and edit the CD schedule.
    2. Remove the association for the default Monitoring Profile from the Collection Group(s) with target devices.
    3. Associate the new custom Monitoring Profile to the Collection Group(s) with target devices.
  2. For a specific device there are two easy paths:
    1. Update the specific Metric Family.
      1. In the Portal UI navigate to Administration->Monitored Items Management->Monitored Devices
      2. Find and select the target device.
      3. Select it's Polled Metric Families tab
      4. Select the white space for the line showing:
        • Metric Family: System
        • Vendor Certification: System Statistics
      5. Select the Update Metric Family button
      6. When the Status column returns to a Supported state the update is complete.
      7. Check the Details tab to confirm the relevant value was updated.
    2. Rediscovery run.
      1. In the Portal UI navigate to Administration->Monitored Items Management->Monitored Devices
      2. Find and select the target device.
      3. Select the Rediscover button at the bottom of the devices Details tab.
  3. For multiple devices run a Discovery Profile with their IPs in the IP List.

Additional Information

The following would be Enhancement Requests:

  • Ability to edit default Monitoring Profile CD schedules.
  • Ability to view default Monitoring Profile CD schedules in the UI without copying the relevant Monitoring Profile.
  • Changing the CD schedule set on System Information OOTB Monitoring Profile.