Upgrade to 21.2.6 has broken failover
search cancel

Upgrade to 21.2.6 has broken failover

book

Article ID: 234963

calendar_today

Updated On:

Products

CA Spectrum DX NetOps

Issue/Introduction

We recently upgraded our Test environment to 21.2.6 in preparation for our Production upgrade.

There are missing data in the "MapUpdate -v" output.

 

Connecting to Location Server running at: server1 port 0xdaff

Landscape   Service Type Name  Hostname                       Port   Precedence  Notes
----------  ------------------ ------------------------------ ------ ----------  ------------------
0x100000    Events             server1                        0xbafe 10          1M model mask
0x100000    Landscape Default  server1                        0xbeef 10          1M model mask
0x100000    Landscape          server1                        0xbeef 10          1M model mask
0x100000    Landscape          server2                        0xbeef 20          1M model mask

 

Connecting to Location Server running at: server2 port 0xdaff

Landscape   Service Type Name  Hostname                       Port   Precedence  Notes
----------  ------------------ ------------------------------ ------ ----------  ------------------
0x100000    Landscape Default  server1                        0xbeef 10          1M model mask
0x100000    Landscape          server1                        0xbeef 10          1M model mask
0x100000    Events             server2                        0xbafe 20          1M model mask
0x100000    Landscape Default  server2                        0xbeef 20          1M model mask
0x100000    Landscape          server2                        0xbeef 20          1M model mask

 

.history file
10.4.2.0.189 08/10/2020 10:13
21.2.6.0.30 01/28/2022 10:53

Environment

Release : 21.2

Component : Spectrum Core / SpectroSERVER

Cause

There is an incorrect hostname in two configuration files.

1) $SPECROOT/LS/.locr file on the server2 (Secondary SS/OC):

LOC_SERVER_SOCKET_NUMBER=0xdaff
MAIN_LOCATION_SOCKET_NUMBER=0xdaff
MAIN_LOCATION_HOST_NAME=server2  <==== Must be server1
MAX_CONNECTIONS=750
orb_args=-Dvbroker.se.iiop_tp.scm.ssl.listener.port=14014 -Dvbroker.se.iiop_tp.scm.iiop_tp.listener.port=14004  -ORBpropStorage ../.corbarc

2) $SPECROOT/tomcat/webapps/spectrum/META-INF/context.xml file on the server2 (Secondary SS/OC):

locServerName="server2" <==== Must be server1

 

This issue was introduced when the same Host Installation Information (HII - hostargs) file that was originally used to install Spectrum 10.4.2 as a standalone SpectroSERVER was also used in the upgrade to 21.2.6

When Spectrum 10.4.2 was installed, the main_loc_serv value was server2 (the server hostname).

But when the Fault Tolerance was established, the MAIN_LOCATION_HOST_NAME was changed to server1, which is the primary MLS hostname. And server2 became the secondary MLS.

main_loc_serv=<
location server
>
The hostname of the Main Location Server (required for all-non patch installations). You can only specify a remote hostname if you are installing a 
SpectroSERVER
.
Note: 
Do not enter an IP address in place of a hostname.

 

To avoid such issues in the production environment, the Host Installation Information (HII - hostargs) file should be updated to refer to the current MLS hostname.

main_loc_serv=server1

Resolution

1. Edit the $SPECROOT/LS/.locr file on the server2 (Secondary SS/OC):

2. Change the following line/row:

From: MAIN_LOCATION_HOST_NAME=server2 

To: MAIN_LOCATION_HOST_NAME=server1

3. Save the change.

4. Edit the $SPECROOT/tomcat/webapps/spectrum/META-INF/context.xml file on the server2 (Secondary SS/OC):

From: locServerName="server2"

To: locServerName="server1"

4. Either kill the LocServer (processd will launch a new one) or stop the SpectroSERVER and processd and then start them back. Wait a couple of minutes for Locserver to talk to each other.

5. Stop/start the Spectrum Tomcat service to put the context.xml file change in place.

Additional Information

https://techdocs.broadcom.com/us/en/ca-enterprise-software/it-operations-management/spectrum/21-2/installing-and-upgrading/fresh-install/sradmin-installation-methods.html