iis probe unable to read perfmon counter SMS Distribution Points Pool
search cancel

iis probe unable to read perfmon counter SMS Distribution Points Pool

book

Article ID: 234898

calendar_today

Updated On:

Products

DX Unified Infrastructure Management (Nimsoft / UIM) DX Unified Infrastructure Management (Nimsoft / UIM) CA Unified Infrastructure Management SaaS (Nimsoft / UIM) Unified Infrastructure Management for Mainframe

Issue/Introduction

The iis probe is unable to read one particular perfmon counter, although its visibile in perfmon application itself fine.

perfmon counter that is erroring is

iis: Added monitor 'APP_POOL_WAS'/'Current Application Pool State'/'SMS Distribution Points Pool'
iis: Host: localhost Failed to add monitor 'APP_POOL_WAS'/'Current Application Pool State'/'SMS Distribution Points Pool'

perfmon.log:

perfmon: GetNameStrings : Fetching counters from english locale
perfmon: GetNameStrings - Open registry local machine key SOFTWARE\Microsoft\Windows NT\CurrentVersion\Perflib\009
perfmon: GetNameStrings - Query registry info on opened key
perfmon: GetNameStrings - largest value = 0
perfmon: GetNameStrings - Query registry value of Counter
perfmon: Error from GetNameStrings - RegQueryValueEx (Counter): The system cannot find the file specified.

Environment

Release : 20.4

Component : UIM - IIS

Cause

- Missing registry key

Resolution

Error from GetNameStrings - RegQueryValueEx (Counter): The system cannot find the file specified.

This error means that the Windows standard API RegQueryValueEx is failing to get the registry handle for key

   HKEY_LOCAL_MACHINE\Software\Microsoft\WindowsNT\CurrentVersion\Perflib\009 

under HKEY_LOCAL_MACHINE, go to registry editor using regedit command and check the key and value:
   HKEY_LOCAL_MACHINE\Software\Microsoft\WindowsNT\CurrentVersion\Perflib\009 

counter value. It should display the counters and their associated values.
NOTEThe counter under the 009 registry hive must be in English, not localized language.
If the counters are not available. Please follow below Microsoft links to manually rebuild Performance Counters. 

https://support.microsoft.com/en-us/kb/300956 
In this case/scenario the key was missing so the customer imported the registry key from another system.