Exported standard from CCS cannot be imported back
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Exported standard from CCS cannot be imported back

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Article ID: 234857

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Updated On:

Products

Control Compliance Suite Standards Server Control Compliance Suite

Issue/Introduction

Once the built-in standard "CIS Benchmark for Red Hat Enterprise Linux 8 v1.0.0 Level 1" is exported from the Control Compliance Suite console it cannot be imported back.

We found that this strange behavior is triggered when you open a command based check which exceeds the 512 characters limit in the command field (ex. check name- "1.4.2 Ensure filesystem integrity is regularly checked"). When this is done and you export the standard and try importing it back you will get an error "Command details are missing for one or more command checks in 'CIS Benchmark for Red Hat Enterprise Linux 8 v1.0.0 Level 1_Command.xml' file."

Cause

Default setting for Command Based check is 512 characters long.

Or an issue with the exported Standard.

Resolution

Make sure the Standard was exported correctly.  Try export and import again, may take a couple of tries.

Or increase the Command Based characters that are allow by following these steps.

Increase the number of Command Based characters by editing the AppserverService.exe.config, make sure to backup the file prior to making any edits. 

Located at <InstallDir>\Symantec\CCS\Reporting and Analytics\Application Server\

You will need administrator rights in notepad or whichever text editor you use to save the file.

Find the following entry and increase the "512" to the required number of characters. e.g. 1024.

<add key="CustomCommandTextLengthLimit" value="512" />

Modify to:

<add key="CustomCommandTextLengthLimit" value="1024" />

Save the file.

Then stop the Application Server service. 
Open Task Manager and wait until the AppserverService.exe is no longer running.
Then restart the Application Server service.

You should no longer see errors about the Command being longer than 512 characters.

Additional Information

If the above steps fail to work, delete the predefined standard out of CCS.

Then re-install the predefined standard using the content installer located in Windows Programs and  Features, via Uninstall/Change option.