Agent does not download the SD Package from Collaborative Agent
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Agent does not download the SD Package from Collaborative Agent

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Article ID: 234813

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Updated On:

Products

CA Client Automation - IT Client Manager CA Client Automation CA Client Automation - Software Delivery

Issue/Introduction

SD Agent does not download the SD Package from collaborative agent.

It downloads it from its Scalability Server.

In TRC_SDAGENT*.log there are these lines :

160222-12:04:01.5125761L|005828|00000b34|SDAgent |SDAgent |sdjobclientif.cpp |001788|INFO | GetJobPackage(): Download package from Collaborating agents
160222-12:04:01.5125976L|005828|00000b34|SDAgent |SDAgent |sdjobclientif.cpp |004300|INFO | GetPackageFromCA(): Download package from Collaborating agent: <computername>.localdomain
160222-12:04:01.5126911L|005828|00000b34|SDAgent |SDAgent |sdjobclientif.cpp |003622|DETAIL | Request package from Collaborating Agent: <computername>.localdomain
160222-12:04:01.5127188L|005828|00000b34|SDAgent |cfUtilities |cfUtilities |000000|DETAIL | CFIMessage::getMessageXML: xmlmsg: <message version="1.0.0.0"><Message version="0.0.0.0"><Message>
<Head>
<Type>16</Type>
</Head>
<Body>
<JP><SWUID>0E895400-AB32-45F9-906C-90E366607B63</SWUID>
<FH>89616640</FH>
<ENCRYPT>1</ENCRYPT>
<THROTTLE>-1</THROTTLE>
</JP>
</Body>
</Message>
</Message></message>

The answer with status 1 is received from collaborating agent indicating a problem :

160222-12:04:01.9175786L|005828|00000b34|SDAgent |cfUtilities |cfUtilities |000000|DETAIL | CFIMessage::create: <message version="1.0.0.0"><Message version="0.0.0.0"><Message>
<Body>
<Status>1</Status>
</Body>
</Message>
</Message></message>
160222-12:04:01.9176514L|005828|00000b34|SDAgent |SDAgent |camif.cpp |000347|DETAIL | Inbound data received, name:Message, version:0.0.0.0
160222-12:04:01.9176739L|005828|00000b34|SDAgent |SDAgent |camif.cpp |000360|DETAIL | Got a response
160222-12:04:01.9176958L|005828|00000b34|SDAgent |SDAgent |sdjobclientif.cpp |003629|DETAIL | Package download request succeded..

 

Environment

Client Automation 14.0 SP2 - 14.5 CU1

Cause

This problem could occur if on the Collaborative Agent the SD TMP directory has been configured to another location.
The default path is C:\Program Files (x86)\CA\DSM\SD\TMP
 
this directory contains the zip of SD Packages.
 
This directory could be changed to another location with this command
ccnfcmda -cmd Setparametervalue -ps /itrm/usd/shared -pn insttemppath -v "newpath"
 
Example :
ccnfcmda -cmd Setparametervalue -ps /itrm/usd/shared -pn insttemppath -v "D:\CA\SD\TMP"
 
Following command could be used to check its current value :
ccnfcmda -cmd Getparametervalue -ps /itrm/usd/shared -pn insttemppath
 
If the command returns an empty string, then default path is used.

Resolution

Open a Case at CA Broadcom technical Support requesting the fix T533358 (for 14.0 SP2) or T533362 (14.5 CU1)
 
This fix should be installed on the collaborative agents (but it could be installled on all SD Agents)
 
sdagt_ft plugin should be restarted :
 
caf stop sdagt_ft
Install the fix T533358
caf start sdagt_ft