Jasper reporting server does not start with Address already in use: NET_Bind
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Jasper reporting server does not start with Address already in use: NET_Bind

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Article ID: 234809

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Updated On:

Products

Clarity PPM On Premise Clarity PPM SaaS

Issue/Introduction

There is a problem with reporting server, the service does not start. We have tried to restart service and server several time and it is impossible to log in Jasper console.

Tomcat logs:

15-Feb-2022 13:48:01.409 SEVERE [main] org.apache.catalina.core.StandardServer.await Failed to create server shutdown socket on address [localhost] and port [8005] (base port [8005] and offset [0])
 java.net.BindException: Address already in use: NET_Bind

Cause

The bind error in the log indicates possible port conflict where another application that is consuming the tomcat ports (startup/shutdown)

Resolution

Consult the OS admin to run OS commands like lsof -i:8080 or netstat -ano to identify applications using the port

For Windows:

  1. Search Resource Monitor in the Windows Start Menu.
  2. Click on Network tab.
  3. Select the TCP Connections tab.
  4. Order by Local Port.

Solution

Once identified - pick either of the below options:

  • Stop the conflicting application
  • Move the conflicting application to another port
  • Modify Jaspersoft ports in $Jasper_Tomcat9\conf\server.xml to use a different port for Jaspersoft

Additional Information

Example: For a customer it was found that a newly deployed SMS Agent Host service was running on the tomcat port 8005 and conflicting with tomcat service used by Jaspersoft. Stopping it resolved the issue.