APM Agent unable to connect to APM SaaS via CloudProxy
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APM Agent unable to connect to APM SaaS via CloudProxy

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Article ID: 234807

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Updated On:

Products

CA Application Performance Management SaaS DX APM SaaS DX Application Performance Management

Issue/Introduction

You are unable to connect Infrastructure agents to your SaaS tenant via the cloud proxy. Similar agents have been connected to other tenants

Using ATC Metric View no sign of agent.  Sustainability metrics only show 1 agent which appears to be DxC agent.

Environment

Release : SAAS

Cause

The Cloud Proxy had been configured with incorrect token type in the apm.server.token property in the application.yml.

Below message in the log indicates that a tenant token had been used instead of an agent token. 

2022-02-10 xx.xx.xxx.xxxx  WARN token type class com.ca.apm.common.rest.SessionTenantToken not supported by loadbalancer

 

Resolution

1) Create an Agent token

2) Open the application.yml

3) Update the apm.server.token property with the correct Agent token

Additional Information

https://techdocs.broadcom.com/us/en/ca-enterprise-software/it-operations-management/dx-apm-saas/SaaS/configure-your-monitoring-environment/Download-Additional-Tools/migrate-agents-using-cloud-proxy1.html#concept.dita_e5552e4232322e9de844fa9251eb951624058f6d_SetUpCloudProxy