Adhoc View filter has 2 languages
search cancel

Adhoc View filter has 2 languages

book

Article ID: 234612

calendar_today

Updated On:

Products

Clarity PPM On Premise Clarity PPM SaaS

Issue/Introduction

When you have multiple languages selected for the data warehouse, on ad-hoc views, the filters for lookups show all the languages, not filtering for the user's language.

 

 

Environment

Release : 15.9.3 16.0, 16.0.1, 16.0.2

Component : CLARITY JASPERSOFT

Cause

1. Create a static lookup
2. Add some values
3. In the lookup Values / Translate change the name of the French one (or any other language).  

-- Add the attribute to a Custom Master Object

4. Create a lookup attribute on one of the custom objects.  If there is not a custom object, create one.
   - Use the lookup created in step 1.
   
 -- Add values to the object instances
 
5. Go to the list page for the master object you are using
6. Configure it to add the attribute you created.
7. Add the values to existing records or create new records and add the values.  

8. On Administration System Options, add that language to the Data Warehouse Options / Lanuages so you have more than one, including the one you changed the language for on the lookup values.

9. Run Full Load Data Warehouse

10. Once completed Create Ad-Hoc off the Custom Master Object Domain and your specific Object.
11. Create filter with the attribute you created

Expected Results:  Filter only shows the values for one language

Actual Results:    Filter shows values for each language

Resolution

Note: This is only for the filter, but the attribute works fine in the body.  If you filter on the wrong language it removes the value from the body.

Workaround: None

Reported as Defect: DE63690

Note: Defect: DE63690 has been resolved Clarity 16.0.3