Rest clients doesn't work with CA PM Data Aggregator on version 21.2.6 - we receive a response "Forbidden".
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Rest clients doesn't work with CA PM Data Aggregator on version 21.2.6 - we receive a response "Forbidden".

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Article ID: 234592

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Updated On:

Products

DX NetOps CA Performance Management - Usage and Administration

Issue/Introduction

If we do a rest request directly to the Ca PC with a rest client everything works fine,

If we do a rest request to the DA using postman for example, we are redirect to the Ca PC for login but after the login the request is not redirect again to the DA.

If we use a rest client directly inside a browser we have exactly the same behavior. If in the browser before a rest call we do a Odata or CA PC login and then do a rest request everything works perfectly!

None of these clients works:
- Postman
- Insomnia
- soapui

When we do a request, the API takes too long to respond an at the end we receive a response "Forbidden".

 

Environment

Dx NetOps Performance Management 21.2+

Cause

Communication Ports are blocked by Firewall

Resolution

Communication port 8382 between DA and CAPC is blocked 

Please ensure that the all required communication ports are opened

 

Additional Information

For complete set of ports refer below document link

https://techdocs.broadcom.com/us/en/ca-enterprise-software/it-operations-management/performance-management/21-2/installing/review-installation-requirements-and-considerations.html#concept.dita_669f11a1a7b734ff07869f266794dc77910ebbf3_FirewallandConnectivityConsiderations