Unable to connect to CAMM via HTTP
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Unable to connect to CAMM via HTTP

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Article ID: 234469

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Updated On:

Products

CA Performance Management - Usage and Administration DX NetOps

Issue/Introduction

Unable to connect to our prod CAMM. Browser keep inserting https:. I can connect to our Dev in FireFox. Prod with FireFox keeps inserting https:. Chrome keeps putting https: for all.

Browser constantly redirects HTTP URLs to HTTPS. Mediation Manager is configured for HTTP and it prevents access to the web UI for Mediation Manager.

Environment

All supported Mediation Manager releases

Cause

Environmental browser configuration.

Resolution

It could be one a few possible causes. Most often it is a browser configuration issue but it may also be a local environmental policy causing the constant redirect.

It is a fairly common issue. A  web search for "How to stop Chrome from auto redirecting to HTTPS" returns a few pages like these samples in the top search results.

  • https://howchoo.com/chrome/stop-chrome-from-automatically-redirecting-https
  • https://help.dreamhost.com/hc/en-us/articles/360027022831-Disabling-the-automatic-redirect-to-HTTPS

 

Alternatively solution is to set up HTTPS for Mediation Manager. The browser problem with redirect to HTTPS becomes moot as well as making the environment being more secure. Steps to configure HTTPS for Mediation Manager are found on the Configure Mediation Manager to Use HTTPS documentation.

We are seeing one of two likely root issues when this problem is observed.

  1. The cache/HSTS info is an issue.
  2. Turning off how it handles what it considers "incomplete" urls. By default it makes them https, so for example www.broadcom.com would get turned into https://www.broadcom.com because it doesn't have a "/" in the url.