How to avoid reboot of computer after deployment of an intellirollup package ?
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How to avoid reboot of computer after deployment of an intellirollup package ?

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Article ID: 234335

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Updated On:

Products

CA Client Automation - Software Delivery CA Client Automation CA Client Automation - IT Client Manager

Issue/Introduction

When an IntelliRollup package like "CA - Patch Me - Security IntelliRollup" or "CA - Microsoft OS Extended Support Update - IntelliRollup" is sent to a computer, if some patches need to be installed, a reboot is executed after all patch installation.

How to avoid this on some servers which not be rebooted automatically ?

Environment

Client Automation - Any Versions

Cause

Most of the patches included in the IntelliRollup have Boot level after execution set to "Restart machine after last job"

Resolution

After execution of IntelliRollup script, SD Agent send the list of missing patches to its scalability Server.
Job Container with patches to install are built dynamically on Scalability Server and sent to the Agent. So there is no control about the option "Boot level after execution" within DSM Explorer.
 
As workaround it is possible to configure some computers to never been rebooted by caf.
 
Create or update a configuration policy which should be applied on these machines with this parameter :
 
DSM/Common Components/CAF/General/CAF: Custom reboot command = cmd /c echo.
 
https://api-broadcom-ca.wolkenservicedesk.com/attachment/get_attachment_content?uniqueFileId=VYYdtP6LPjZWTxRO81+kTQ==
 
Every time caf must reboot the computer it will execute "echo" command instead the standard reboot OS method.
This will disable the reboot made by caf.