Agent service doesn’t start after installing 14.0.2 update
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Agent service doesn’t start after installing 14.0.2 update

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Article ID: 234090

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Updated On:

Products

CA Harvest Software Change Manager

Issue/Introduction

After installing the 14.0.2 update, the Harvest Agent Service 14.0.2 fails to start with these behaviors:

1. Trying to start Agent service via the Windows Services console

The CA Harvest SCM Agent Service service failed to start due to the following error:

The service did not respond to the start or control request in a timely fashion.

2. Starting the Agent manually by running 'agntd.exe' from the Harvest Agent install location:

The program can´t start because libcrypto-3-x64.dll is missing from your computer.

Environment

CA Harvest Software Change Manager 14.0.2

All Supported Windows Operating Systems

Cause

Some cripto libraries from SSL are missing.

Resolution

To resolve this problem, the SCM v14.0 Full Client and the SCM v14.0.2 Full Client Refresh Pack patch need to be installed (together with the admin, not just the workbench).

It is necessary to install the client+admin (this includes the workbench) and the agent.

Beware of the warning:

Do not mix the two options on a single computer. For example, if you have installed the client using the Workbench and Administrator option, and you later want to switch and use the Workbench only option, first uninstall the existing client and then install the client again using the Workbench only option.