agent service doesn’t start after installing 14.0.2 update
search cancel

agent service doesn’t start after installing 14.0.2 update

book

Article ID: 234090

calendar_today

Updated On:

Products

CA Harvest Software Change Manager

Issue/Introduction

After installing the 14.0.2 update, the Agent Service 14.0.2 fails to start with these behaviors:

1. Giving the start command on the services.msc console:

The CA Harvest SCM Agent Service service failed to start due to the following error:

The service did not respond to the start or control request in a timely fashion.

2. Executing the agntd.exe:

The program can´t start because libcrypto-3-x64.dll is missing from your computer.

 

 

 

Environment

Release : 14.0.2

Component : CA Harvest Software Change Manager

Cause

Some cripto libraries from SSL are missing.

Resolution

To resolve this problem, the SCM v14.0 Full Client and the SCM v14.0.2 Full Client Refresh Pack patch need to be installed (together with the admin, not just the workbench).

It is necessary to install the client+admin (this includes the workbench) and the agent.

Client Installation Options

(Client with Workbench and Administrator.)

beware of the warning:

Do not mix the two options on a single computer. For example, if you have installed the client using the Workbench and Administrator option, and you later want to switch and use the Workbench only option, first uninstall the existing client. Then, install the client again using the Workbench only option.