Attachment errors "DMS-02107", "DMS02104", "API-1035" and "DMSException"
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Attachment errors "DMS-02107", "DMS02104", "API-1035" and "DMSException"

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Article ID: 23362

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Updated On:

Products

Clarity PPM On Premise Clarity PPM SaaS

Issue/Introduction

Running into issues related to document manager / attachments in either Classic Clarity or the Modern User Experience (MUX)

  1. When attempting to upload a document in the Knowledge store or on a Project Collaboration Documents, you encounter the following error message:
    DMS-02107: The system is unable to create the directory in the DMS
  2. When opening existing files, you are trying to open the documents in the knowledge store and encounter the following error messages:
    In Classic: DMS-02104: The system cannot retrieve the requested document from the DMS.
    In New UX:  "com.niku.dms.util.DMSException: "Could not retrieve file from file store"
  3. The error also found on the Modern UX while accessing files just uploaded: "API-1035 : Could not load attachment

Environment

Release: Any

Cause

The error message can occur if the Filestore Directory in the CSA -> Search properties changed or if the Search Index needs to be updated or re-indexed. Clarity's Search and Advanced Search tools allow you to locate documents, events, action items and discussions within the application. These individual items must be indexed in order for the Search and Advanced Search tool to locate them.

Resolution

This applies to On Premise Customers.  If you are a SaaS/GCP customer, create a case with Broadcom Support to investigate the root cause.

Check CSA Configuration:

  1. In CSA, navigate to the Search tab and review the configuration for the Filestore directory.
  2. If it is incorrect:
    1. Correct the details
    2. Restart services
    3. Recreate the search indexes
    4. Restart services again after recreating the indexes.

      Re-Indexing commands:
  • admin search recreate-index-files
  • admin search recreate-index-data 

Run the Index contents and documents for searches job

  1. If the CSA Configuration is ok, execute the 'Index contents and documents for searches' job.
  2. Wait for the job to complete successfully and then attempt to upload the document again.

Sometimes the error message will occur if the 'Index contents and documents for searches' job is actively running at the time the uploading of the document occurs.

  • You only need to run the commands if the entire index for documents or content data needs to be re-created. To index documents and content data incrementally, for items not yet indexed, simply execute the 'Index contents and documents for searching' job.
  • This job must be scheduled on a regular basis to index the content data for searching when your configuration is configured not to use asynchronous indexing. Asynchronous Indexing will automatically index items as they are added.

Index Command Details

  • Run the 'recreate-index-files' command in order to recreate indexes associated with documents in the Knowledge Store and documents in the Project Collaboration, Document Manager tab, and documents on Object Attachment attributes. This command works for discussions that are stored in either the "filestore" or in the "database". The search tools do not return documents attached to Discussions.
  • Run the 'recreate-index-data' command in order to recreate indexes associated with data content for the following items: Project Action Items, Project Discussions, and Process Action Items. The search tool does not return Personal Action Items.

Note: you can use '-info' at the end of each command if you want more information to be provided to the admin.log file when running these commands. This is useful in troubleshooting issues.

Additional Information

Also, reference current documentation CSA: Document Index, Search, Storage, and File Scanning