NetOps Table Hierarchy NFA Data Missing
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NetOps Table Hierarchy NFA Data Missing

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Article ID: 233513

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Updated On:

Products

CA Network Flow Analysis (NetQos / NFA)

Issue/Introduction

While using NetOps Portal and Network Flow Analysis, you may notice that the "Table Hierarchy Protocol by Volume" and "Table Hierarchy Host by Volume" views may be empty.

 

Environment

 

Component : NQRPTA - REPORTERANALYZER

Cause

This could be caused by a harvester server with multiple NIC cards. 

Resolution

Got to the NFA Console server and search for the latest x:/ca/nfa/reporter/logs/PumpServicelog.

In there you should see a log of FLT and RPR files being pulled from the harvesters to be processed by the NFA Console. Ensure the FLT and RPR files have the proper IP address listed in the file names and not the backup NIC card IP Address.

If the FLT or Flow Time file has the wrong IP Address, follow this document to resolve it:

https://knowledge.broadcom.com/external/article/74974/nfa-last-flow-not-updating.html

If the RPR or Reaper file has the wrong IP Address we have no workaround at this point. The RPR files is what is responsible for the 2 above graphs missing data in the Network Interface Performance dashboard.

Defect DE526990 has been opened to make the override value for the FLT files also override the IP Address in the file name. Until this is resolved, in order to make the RPR files be created on the harvester with the right IP Address is to change the priority of the NIC cards on the harvester. This will need to be taken care of by setting metric values for most servers but is different on each operating system.  Once the NIC priority is resolved, restart the CA NFA Harvester Service as well as the CA NFA Reaper Service for the RPR files to be created and processed with the right IP Address.