Error 429 (Too Many Requests) in SAAS
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Error 429 (Too Many Requests) in SAAS

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Article ID: 233482

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Updated On:

Products

Clarity PPM SaaS Clarity PPM On Premise

Issue/Introduction

SUMMARY: Many OPTIONS calls in GCP SSO upon refresh on logout.  All GCP Clarity SaaS customers using Single Sign On, are getting the error 429 (Too Many Requests)  when connecting to Clarity.

 

STEPS TO REPRODUCE:

  1. Ensure that on your system you have added many custom Project sections on Project Properties page, including many attributes
  2. Open a Clarity - Classic UI tab
  3. Now open MUX in another tab
  4. Now open a Project in MUX tab using the same blueprint with many attributes on Properties tab <servername>/pm/#/project/5207353/details 
  5. Go to Tasks subpage
    In MUX tab, enable Dev Tools
  6. In Classic tab, hit Logout
  7. Go back to MUX tab, click on Properties

Expected Results: To be able to be redirected without excessive OPTIONS calls

Actual Results: You are logged out and lots of Options calls and errors in the Dev Tools, which may overwhelm the SSO connection rate limit and cause 429 Too Many Connections error in Okta

 

Environment

Release: 16.0.0, 16.0.1 

Cause

DE64244 

  • This is an issue with Okta connection limit 
  • The limit has been increased which should take care of most of the overflow 
  • Updates will be sent via the status page 

 

Resolution

Fixed in a pre-patch on 16.0.1 (applied to Production SAAS). 

Resolved in 16.0.2 and 16.0.1 Patch #1 (16.0.1.1)