Error: "Access is denied" message while running Network Discover Scan on NFS share which required anonymous access.
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Error: "Access is denied" message while running Network Discover Scan on NFS share which required anonymous access.

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Article ID: 233451

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Updated On:

Products

Data Loss Prevention Network Discover Data Loss Prevention

Issue/Introduction

Scanning an NFS share using Network Discover fails with the message an "Access is denied" message. The scan detail logs collected from the Network Discover server we can see the following: 

[SEVERE] (DISCOVER.103) Incorrect Username/Password "domain\username" for share specified: "\10.x.x.x\vol\share_target_name"

[INFO] (DISCOVER.122) Failed to open content root nfs:"//10.x.x.x/vol/share_target_name", reason Access is denied.

Cause

The NFS share is configured to use anonymous access. 

Resolution

  1. In the Enforce console navigate to the Discover Targets -> Scanned Content tab. (Manage > Discover Scanning > Discover Targets)
  2. Under "Default User" select the "Use These Credentials:" button and remove all information present so the fields Name, Password and Confirm Password are left blank.
  3. Save the Scan Target and run the scan again.

You should now see the scan running successfully now.