Access Denied message while running Network Discover Scan on NFS share which required anonymous access.
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Access Denied message while running Network Discover Scan on NFS share which required anonymous access.

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Article ID: 233451

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Updated On:

Products

Data Loss Prevention Network Discover

Issue/Introduction

When we scan a NFS share using Network Discover it fails with the message an access denied message. The scan detail logs collected from the Network Discover server we can see the following: 

[SEVERE] (DISCOVER.103) Incorrect Username/Password "domain\username" for share specified: "\10.x.x.x\vol\share_target_name"

[INFO] (DISCOVER.122) Failed to open content root nfs:"//10.x.x.x/vol/share_target_name", reason Access is denied.

Environment

Release: 15.7

Component: Default-Sym

Cause

The NFS share is configured to use anonymous access. 

Resolution

In the Enforce console navigate to the Scan Target -> Scanned Content tab

Then select the "Use These Credentials:" button and remove all information present so the fields Name, Password and Confirm Password are left blank.

Save the Scan Target and run the scan again.

You should now see the scan running successfully now. 

Additional Information

For NFS it is a best practice to add the exclude filter to avoid scanning the .snapshot.

You can find more information and examples on configuring the scan target in the online help:

15.7 - Configuring scans of file systems

15.8 - Configuring scans of file systems