CA Patch Me execution failed. The job at the indicated target computer timed out after having been initiated. [SDM228410]
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CA Patch Me execution failed. The job at the indicated target computer timed out after having been initiated. [SDM228410]

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Article ID: 233366

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Updated On:

Products

CA Client Automation - IT Client Manager

Issue/Introduction

Execution of job for a "UPM - CA - Patch Me - Security IntelliRollup" is failing with error :

Job execution failed. The job at the indicated target computer timed out after having been initiated. [SDM228410]
 
In TRC_USD_SDAGENT*.log following error appears :
 
291221-11:33:11.2508025L|002372|00002a64|SDAgent|sdjecontainerif.cpp |001226|NOTIFY | Running SD job 1: UPM - CA - Patch Me - Security IntelliRollup v2112.00 - {3bc1bb8e-1bde-4d1d-abf7-94c7823eb9c4} Silent Install 1.0
291221-11:33:12.2430897L|002372|00002a64|SDAgent|sdjesdprocedureexecu|000533|NOTIFY | SDJESDProcedureExecutorIf::Execute executing DMSCRIPT.EXE 3bc1bb8e-1bde-4d1d-abf7-94c7823eb9c4-0.dms    C:\PROGRA~2\CA\DSM\Agent\units\00000001\usd\sdjexec\DE5D6D0C-B249-4330-BEB4-4E7943378130.res NOREBOOT
291221-17:33:13.0126997L|002372|00002a64|SDAgent|sdjeinterface.cpp   |000431|NOTIFY | Execution time out occurred
291221-17:33:13.6631608L|002372|00002a64|SDAgent|sdjecontainerif.cpp |001402|NOTIFY | SDjob 1 returns: 16 ExitCode: 0
291221-17:33:13.6632031L|002372|00002a64|SDAgent|sdjecontainerif.cpp |002721|NOTIFY | Execution not OK
 
 
Cause 1 : In C:\windows\temp\MS_Rollup\cabScan.log, we can see that powershell script cabScan_pm.ps1 is still running :
<----- START ----->
OS Version = 10.0 
OS CodeName = win10 
OS Architecture = x64 
Cab Files Count = 13
...
     ----- win10-server-kb5009545-x64-1909.cab -----
Scanning cab file - win10-server-kb5009545-x64-1909.cab 
win10-server-kb5009545-x64-1909.cab - Not Applicable
     ----- win10-server2016-kb5005698-x64-1607.cab -----
Scanning cab file - win10-server2016-kb5005698-x64-1607.cab

 

Cause 2 : In C:\windows\temp\MS_Rollup\cabScan.log, we can see that 

<----- START ----->
OS Version = 6.3 
OS CodeName = windows8.1 
OS Architecture = x64 
Cab Files Count = 0
Cab Scan has been completed.
Number of Cab Files Scanned = 0

and in C:\windows\temp\MS_Rollup\MS_OS_Rollup_*.log last lines are :

File C:\Windows\temp\MS_Rollup\cabScanResult.txt does not exist.
Attempt to execute cab scan powershell script without parameters...

Environment

Client Automation 14.5

Cause

Cause 1 : This problem could be caused by a problem in directory C:\Windows\SoftwareDistribution

 

Cause 2 : This problem is caused by a SD Package "UPM - CA - Patch Me - Security IntelliRollup" without .cab files inside

A Patch Me Security IntelliRollup package should contain a lot of .cab files :

Resolution

Solution for Cause 1 :
 
Do this on the Agent with problem to rebuild the directory C:\Windows\SoftwareDistribution :
 
1- Execute these commands :
 
net stop wuauserv
net stop bits
 
If wuauserv has problem to be stopped, try the solution 1 of this article :
https://appuals.com/fix-windows-update-service-could-not-be-stopped/
  
2- Rename the directory C:\Windows\SoftwareDistribution as C:\Windows\SoftwareDistribution.old
 
3- Execute these commands :
 
net start wuauserv
net start bits

 
 
Solution for Cause 2:
Download again the Patch Me Security IntelliRollup package from Patch Manager

Additional Information

See https://www.windowscentral.com/how-clear-softwaredistribution-folder-windows-10