IPSLA tests discovered but views show "No Data to Display"
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IPSLA tests discovered but views show "No Data to Display"

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Article ID: 233203

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Updated On:

Products

CA Performance Management - Usage and Administration

Issue/Introduction

IPSLA tests are discovered but return no data when polled.
The tests discovered are valid IPSLA tests as configured on the device.

Environment

Release : All supported releases

Component : IM Polling

Cause

In the "Detailed Poll Logging" dcdebug output we see sysUpTime reported as returning null

MMM DD HH:MM:SS.###: CiscoIPSLADynamicDiscovery processed discovery: baseOID=1.3.6.1.4.1.9.9.42.1.3.5.1.4.INDEX
 userObject=ItemBasedRequestState[responseReceivedTimestamp=UNIXTIMESTAMP(DDD MMM DD HH:MM:SS TZ YYYY), itemList=[ITEMID]] ,discoveryIntf=com.ca.im.dm.snmp.collector.ipsla.discovery.process.CiscoIPSLAInitialState@#######,
 discoveryResult=sysUpTime=null, fullOID=1.3.6.1.2.1.1.3.0, dynamicIndex=null ,discoveryState=FAILED, currentDynamicIndex=null

This is because when we poll the item, the device returned sysUpTIme as type Integer32, not TImeTicks as it should be and as expected by DX Netops Performance Management

A sapwalk may show sysUpTime as type TImeTicks, but the type returned when polled is Integer32.
This can be confirmed using a packet capture of the polling activity to the device.

Resolution

Contact the device vendor, as this is a device issue.