SMTP notifications sent by Enforce are not reaching its recipient.
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SMTP notifications sent by Enforce are not reaching its recipient.

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Article ID: 233092

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Updated On:

Products

Data Loss Prevention Enforce

Issue/Introduction

SMTP notifications sent by Enforce for either incident notifications or reports are not working. You may see in the Incident Snapshot -> History tab an entry that says "Notification Sent: Incident notification sent to null". 

In the SymantecDLPManager log, you may find the following entries:

INFO   | jvm 1    | 550 5.7.60 SMTP; Client does not have permissions to send as this sender
INFO   | jvm 1    | DEBUG SMTP: got response code 550, with response: 550 5.7.60 SMTP; Client does not have permissions to send as this sender

Cause

The SMTP server may be configured so that accounts authenticating to the SMTP server can then only send e-mails using their assigned e-mail address as sender. If an account authenticates to the SMTP server and then tries to send an e-mail using an e-mail address which doesn't belong to that account, this is what the SMTP server will send in that SMTP response. As a result, the SMTP server blocks the mail send attempt. 

Resolution

In the case of the integration of Enforce-SMTP server, we are talking about the following two config parameters in Enforce's SMTP settings (located in the System | Settings | General menu):

  1. User ID - this is the account that Enforce will use to authenticate to the SMTP server
  2. System Email - this is the e-mail address that Enforce will use in all notifications (incidents, reports, alerts etc.) as mail sender

The above error suggests that Enforce is configured in a way that the e-mail address defined in System Email does not belong to the account configured in User ID. 

This should be fixed by either:

  • Configuring a User ID and System Email in Enforce which belong to a single user
  • OR using Anonymous SMTP if you're using DLP 15.7 MP3 or 15.8 MP2 (as these versions contain a fix for issues seen earlier with Anonymous SMTP and MTAs which have authentication enabled, which did not allow to save Anonymous SMTP settings in Enforce)