HTTP REQUEST TIMEOUT WebSphere hung OM Web Viewer 12.1
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HTTP REQUEST TIMEOUT WebSphere hung OM Web Viewer 12.1

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Article ID: 232994

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Updated On:

Products

Output Management Web Viewer

Issue/Introduction

Production Web Viewer v12.1 had an issue with HTTP Timeout.  Initial recycling of WAS servers provided no relief.

STC BBOO0327I HTTP REQUEST TIMEOUT:  003

Environment

  • Output Management Web Viewer 12.1
  • IBM WebSphere 8.5

Cause

Post event analysis revealed a user triggered the problem when they tried to SMTP mail an attachment in excess of 4 Gig. Logs also showed there were only 30 threads available. max heap was only 3 Gig,

The user requesting over 4 GB of data quite possibly hung the WAS server. There could have eventually been an OutOfMemory exception because of the Java Heap Size was set to 3 GB maximum.

Resolution

Recycling WebSphere servers resolved the problem (though there may have been underlying network issues resolved prior to the recycle).

Recommended

  1. Increase-xmx to at least 4 gig from the WebSphere console
  2. Push the thread count higher than the 32 current setting.
  3. Apply the latest maintenance for Web Viewer.
  4. Avoid the problem in the future by by limiting the number of file pages allowed to be attached to emails. This is located in Administration->Role-><selected User Role>->Properties where you can "Enable with page limit". 

Additional Information

it is a good idea to enforce some limits to downloads in coordination with the User's Business Requirements.