HTTP REQUEST TIMEOUT and WAS Server hung - 12.1.6.204 Web Viewer/WebSphere 8.5.5.20
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HTTP REQUEST TIMEOUT and WAS Server hung - 12.1.6.204 Web Viewer/WebSphere 8.5.5.20

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Article ID: 232994

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Updated On:

Products

Output Management Web Viewer

Issue/Introduction

Production Web Viewer v12.1 had an issue with HTTP Timeout.  Initial recycling of WAS servers provided no relief.

07.56.28 STC28582  BBOO0327I HTTP REQUEST TIMEOUT:  003

Environment

Release : 12.1

Component : OUTPUT MANAGEMENT WEB VIEWER FOR ALL PLATFORMS

Cause

Post event analysis revealed a user triggered the problem when they tried to SMTP mail an attachment in excess of 4 Gig. Logs also showed there were but 30 threads available. max heap was only 3 Gig,

RCA -  the user requesting over 4 GB of data quite possibly hung the WAS server. There could have eventually been an OutOfMemory exception because of the Java Heap Size was set to 3 GB maximum.

Resolution

Recycling WebSphere servers resolved the problem (though there may have been underlying network issues resolved prior to the recycle).

Recommended increasing -xmx to at least 4 gig from the WebSphere console, also pushing thread higher than the 32 current setting. Also recommended updating to Build 218 of 12.1 Web Viewer so as to make available Chrome and Edge browser use, whilst avoiding other know problems. And recommended working around the problem cause by limiting the number of file pages allowed to be attached to emails. This is located in Administration->Role-><selected User Role>->Properties where you can "Enable with page limit". 

Additional Information

it is a good idea to enforce some limits to downloads in coordination with the User's Business Requirements.