Symantec VIP Enterprise Gateway LiveUpdate fails with error WMI Operation failure: ServiceCannotAcceptControl
search cancel

Symantec VIP Enterprise Gateway LiveUpdate fails with error WMI Operation failure: ServiceCannotAcceptControl

book

Article ID: 232914

calendar_today

Updated On:

Products

VIP Service

Issue/Introduction

VIP Enterprise Gateway LiveUpdate fails. The following error is seen in the VIP_Enterprise_Gateway\logsupdate.log:

INFO  "2022-01-19 20:10:29.158 GMT-0500" 172.23.10.220 upgrade 0 0 0  "actor=upgrade,op=upgrade,text=Successfully stopped ldapSync service"
...
INFO  "2022-01-19 20:10:32.041 GMT-0500" 172.23.10.220 upgrade 0 0 0  "actor=upgrade,op=upgrade,text=Process result: 2022-01-19 20:10:32\,031 FATAL - WMI Operation failure: ServiceCannotAcceptControl"
INFO  "2022-01-19 20:10:32.041 GMT-0500" 172.23.10.220 upgrade 0 0 0  "actor=upgrade,op=upgrade,text=Process result: WMI.WmiException: ServiceCannotAcceptControl"
INFO  "2022-01-19 20:10:32.042 GMT-0500" 172.23.10.220 upgrade 0 0 0  "actor=upgrade,op=upgrade,text=Process result:    at WMI.WmiRoot.BaseHandler.CheckError(ManagementBaseObject result)"
INFO  "2022-01-19 20:10:32.042 GMT-0500" 172.23.10.220 upgrade 0 0 0  "actor=upgrade,op=upgrade,text=Process result:    at WMI.WmiRoot.InstanceHandler.Invoke(Object proxy\, MethodInfo method\, Object[] args)"
INFO  "2022-01-19 20:10:32.043 GMT-0500" 172.23.10.220 upgrade 0 0 0  "actor=upgrade,op=upgrade,text=Process result:    at winsw.WrapperService.Run(String[] _args\, ServiceDescriptor descriptor)"
INFO  "2022-01-19 20:10:32.043 GMT-0500" 172.23.10.220 upgrade 0 0 0  "actor=upgrade,op=upgrade,text=Process result:    at winsw.WrapperService.Main(String[] args)"

Cause

The LDAP Sync Simulation Service (Symantec LDAP Sync Service) is removed from the Windows services console when an LDAP sync simulation is not running and creates the service when it is.  This service should be visible in the services console only when a simulation is in progress. Otherwise, the LiveUpdate may fail.

This does not apply to the actual LDAP synchronization service (Symantec LDAP DirSync Service). This service will reflect the status shown in the VIP Console. 

Resolution

  • From the Windows Services console, manually stop all Symantec LDAP services.
  • From the VIP EG console, click User Store > LDAP Directory Synchronization, then click the Run Simulation button. The Symantec LDAP Sync Service will show as 'Running' in the Windows services console. 
  • When the simulation is complete (look for Sync Done... End in the progress window), click Stop Simulation, then click Continue to stop. The Symantec LDAP Sync Service should no longer be seen in the Windows services console after refreshing the screen. 
  • Navigate to \Program Files (x86)\Symantec and delete the .BAK file created during the earlier LiveUpdate attempt. 
  • Restart the Symantec VIP Enterprise Gateway service, then launch LiveUpdate from the console. 

Additional Information

Supported EGW versions 9.8.4, 9.9.x