Jobs get stuck if there is disruption in database connection
search cancel

Jobs get stuck if there is disruption in database connection

book

Article ID: 232853

calendar_today

Updated On:

Products

Clarity PPM On Premise Clarity PPM SaaS

Issue/Introduction

Processes and Jobs get stuck if there is a disruption in the database connection. If a job is stuck, data is not refreshed and Clarity is heavily relying on different jobs for data updates. This has an impact if the architecture is to run Clarity with a multi-node database setup.

Expected Results: As soon as the database connection is restored, the jobs should resume.

Actual Results: Jobs are stuck and we see Database Connection errors in the bg-ca.log.

Environment

Release 15.9.2, 15.9.3, 16.0.0, 16.0.1 

Cause

DE61619 

Workaround: Restart the BG services or manually cancel, delete and reschedule a job.

 

Resolution

Resolved in 16.0.2 and 16.0.1 Patch #1 (16.0.1.1)