Error 500 thrown when clicking on Properties/Detail tab of a Cost Plan
search cancel

Error 500 thrown when clicking on Properties/Detail tab of a Cost Plan

book

Article ID: 232646

calendar_today

Updated On:

Products

Clarity PPM On Premise Clarity PPM SaaS

Issue/Introduction

Steps to reproduce this issue are as follows:

  1. Navigate to Administration -> Processes
  2. Create a new process:
    1. Add Cost Plan as the primary object
    2. Connect Start Step to Finish Step
    3. Validate and Activate the process
  3. Navigate to Home -> Projects
  4. Create a new project:
    1. Populate Department and Location
    2. Create a Cost Plan
  5. Click on "Processes" tab within the Cost Plan
  6. Click on "Available" sub page
  7. Click on the process from step 2
  8. Click on "Return"
  9. Click on "Properties" tab of the Cost Plan

Expected Results: Properties of the Cost Plan are shown

Actual Results: Following error is thrown in the UI

Error 500 - Internal Server Error. The server could not retrieve the document due to server-configuration or other technical problems. Contact your site administrator.

Following error is seen in app-ca.log:

ERROR 3122-01-20 02:49:33,433 [http-nio-8080-exec-34] web.WebActionController (clarity:admin:5281514__3-BE50-4FBA-AB74-ED83A8E15A2E:revmgr.costplanProperties) 
com.niku.union.web.WebException: Service call failed for portlet: revmgr.costplanPropertiesTOC
 at com.niku.union.web.PortletController.processAuthorizedPortlet(PortletController.java:944)

Environment

Version: 16.0.0.

Cause

This issue is caused due to DE63842.

Resolution

The defect is fixed in:

  • 16.0.2