Identity Policies are not being loaded after upgrade to 14.4.1
search cancel

Identity Policies are not being loaded after upgrade to 14.4.1

book

Article ID: 232528

calendar_today

Updated On:

Products

CA Identity Suite CA Identity Manager

Issue/Introduction

After upgrading from CA Identity Manager (Symantec IGA) 14.4.0 to 14.4.1 the Identity Policies configured in the Identity Sets are missing.

The policies exist in the Database but they are not being loaded when the application server (Jboss\Wildfly) is restarted. When the environment role and task settings are exported the XML file does not contain the identity policies, just the empty policy sets.

In Modify Identity Policy Set the Policy does not appear.  No error.  After restart and upgrade, continues to not display. If you make no changed, and click submit again it will display and appear in IME export.

Environment

Release : 14.4.0 -> 14.4.1 with Wildfly 15.0.1

Component : IdentityMinder(Identity Manager)

Cause

You will see the start up steps.

Notice between step 4 and 5.  "Object Store cache will be pre-populated asynchronously" 

Resolution

Change the AsynchCachePreload flag to false in the file <iam_ear_location>config\com\netegrity\config\objectstorecache.properties.

 
AsynchCachePreload flag is used to load all managed objects asynchronously.  After setting the flag the policies will load as expected.

 

In a Virtual Appliance environment, request the HF below to change the value of the property in the file.

HF_IMS-14.4.1-20220502123611-DE534556.tgz.gpg

 

Additional Information

Note: This feature is available from 14-4-1. It will improve the startup time and disabling it will not impact any other functionality.

Also,

A hotfix for allowing ID Policies to load while AsynchCachePreload=true is now available:

HF_DE550027.zip