email alerts are not working for a few servers
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email alerts are not working for a few servers

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Article ID: 232507

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Updated On:

Products

DX Unified Infrastructure Management (Nimsoft / UIM) CA Unified Infrastructure Management SaaS (Nimsoft / UIM) Unified Infrastructure Management for Mainframe

Issue/Introduction

Currently we are facing an issue, for a few of our robot email alerts are not triggering even after breaching the configured threshold. We have verified the email alerting configuration in the NAS probe and do not observe any configuration issue. We are able to view alerts in OC as well as in the nas probe logs for that problematic robot, but same is not receiving on mail. Please  be note that we are facing this issue only for few robots, and the rest of the robots for all email alerting are working as expected.

Environment

Release : 20.3

Component : UIM NAS

Cause

- nas AO profile configuration

Resolution

An ampersand character (&) can be added as a User Tag within the robot controller under Misc, but it is not supported for filtering within a nas AO Profile. It won't work, e.g., the filter won't apply and no action will be taken, e.g., EMAIL. You'll notice this in the alarm if you open the alarm from within the alarm subconsole, you'll see that the '&' is stripped out/missing.

ABC & BCD, ABC&BCD will not work.

ABC-BCD, ABC_BCD will work just fine.

Use hyphens (-) or underscores (_) or even spaces between words/strings instead.

We also deselected ALL severities, as there was no reason to select all of them in the nas AO Profile.

Example nas AO Profile:

<basic test of email_1>
         active = no
         action = EMAIL XXX_CCL
         overdue = on_arrival
         visible = 0
         order = 4
         break = no
         user_tag1 = MCX_MCX
      </basic test of email_1>