Information from a custom event is seen in the Spectrum OneClick console but is not see when the alarm is received via e-mail from AlarmNotifier
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Information from a custom event is seen in the Spectrum OneClick console but is not see when the alarm is received via e-mail from AlarmNotifier

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Article ID: 232471

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Updated On:

Products

CA Spectrum

Issue/Introduction

Information from a custom event is seen in the Spectrum OneClick console but is not see when the alarm is received via e-mail from AlarmNotifier

For example, the following event is seen in the OneClick Events tab where it shows the URL after the "KB article -":

However, when the e-mail associated is received from AlarmNotifier, the URL information seen in the Events tab in OneClick is missing.

Environment

Release : Any

Component : Event and Alarm Management

Cause

For this particular issue, upon examining the Event Format file of the 0xfff00e57 event, we see the following:

{d "%w- %d %m-, %Y - %T"} - {d "%w- %d %m-, %Y - %T"} - Device {m} of type {t} has stopped responding to polls and/or externa
l requests.  An alarm will be generated.
KB article \u2013 https://myutl.com

(event [{e}])

 

Notice the \u2013 in the Event Format file.

\u2013 is the unicode character for a dash "-" character.

Resolution

Edit the Eventfff00e57_en_US with a text editor to remove \u2013 and replace it with the "-" character.

Additional Information

If you see a similar issue, check the associated Event Format file for unicode characters and replace as needed.

Attachments