Critical System Protection (CSP) Agents have stopped sending events to CSP Management Server
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Critical System Protection (CSP) Agents have stopped sending events to CSP Management Server

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Article ID: 232440

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Updated On:

Products

Critical System Protection

Issue/Introduction

You can't see CSP Events in the Java Console, but when you log in to CSP Event Viewer on the agent you can see they are generated successfully. 

The connection from the agent to the CSP Manager works and sisipsconfig -t output shows connection successful.

When you examine SISIPSServiceX.log you can see the following exception reporting failed insert to the SCSPDB Discovered_Device table. 

"SCSP Error when trying to send a log. Error Code  300 : Error Message : &quot1;SQL Code: 515&amp1;crlf1;&amp1;crlf2;Cannot insert the value NULL into column 'OptVendorId'&amp1;sep1; table 'SCSPDB.dbo.DISCOVERED_DEVICE'; column does not allow nulls. INSERT fails.&amp1;crlf2;&quot1;"

Environment

Release :8.0.x

Component : SCSPDB

Cause

The insert contains incomplete information and the column does not allow null 

Resolution

If you are seeing in the logs insert failures caused by SCSPDB.dbo.DISCOVERED_DEVICE column does not allow nulls error please contact Broadcom Technical Support and request updated Stored Procedure.