Events not showing up in Spectrum
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Events not showing up in Spectrum

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Article ID: 232437

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Updated On:

Products

DX NetOps CA Performance Management - Usage and Administration

Issue/Introduction

After upgrading to v21.2.6 on Spectrum and PM, events were not seen in Spectrum but created in PM.  

Receiving this error now in the EM Wrapper log 

INFO   | jvm 1    | 2022/01/14 00:26:58 | WARN  | qtp1892386753-39         | 2022-01-14 00:26:58,133 | com.ca.im.portal.api.security.Encryption                         
INFO   | jvm 1    | 2022/01/14 00:26:58 |       | Couldn't complete encryption/decryption due to: Error closing stream: 
INFO   | jvm 1    | 2022/01/14 00:26:58 | WARN  | qtp1892386753-39         | 2022-01-14 00:26:58,133 | com.ca.im.portal.common.web.util.AuthInterceptor                 
INFO   | jvm 1    | 2022/01/14 00:26:58 |       | SsoToken is expired or could not be decrypted

Receiving this error in the tomcat log: 

AxisFault
 faultCode: {http://xml.apache.org/axis/}HTTP
 faultSubcode:
 faultString: (401)Unauthorized
 faultActor:
 faultNode:
 faultDetail:
        {}:return code:  401

        {http://xml.apache.org/axis/}HttpErrorCode:401

(401)Unauthorized
        at org.apache.axis.transport.http.HTTPSender.readFromSocket(HTTPSender.java:744)
        at org.apache.axis.transport.http.HTTPSender.invoke(HTTPSender.java:144)
        at org.apache.axis.strategies.InvocationStrategy.visit(InvocationStrategy.java:32)
        at org.apache.axis.SimpleChain.doVisiting(SimpleChain.java:118)
        at org.apache.axis.SimpleChain.invoke(SimpleChain.java:83)
        at org.apache.axis.client.AxisClient.invoke(AxisClient.java:165)
        at org.apache.axis.client.Call.invokeEngine(Call.java:2784)
        at org.apache.axis.client.Call.invoke(Call.java:2767)
        at org.apache.axis.client.Call.invoke(Call.java:2443)
        at org.apache.axis.client.Call.invoke(Call.java:2366)
        at org.apache.axis.client.Call.invoke(Call.java:1812)
        at com.netqos.InventoryWS.InventoryWSSoapStub.beginInventory(InventoryWSSoapStub.java:504)
        at com.ca.im.netqos.integration.datasource.inventory.AxisNetqosInventoryService.getEventManagerURL(AxisNetqosInventoryService.java:77)
        at com.ca.im.netqos.integration.event.NetqosEventManager$NPCEventManagerWebserviceURLPoller.performTask(NetqosEventManager.java:626)
        at com.aprisma.util.thread.ThreadPoolMonitor$TimedThreadTask.performTask(ThreadPoolMonitor.java:135)
        at com.aprisma.util.thread.CachedThread.run(CachedThread.java:116)
Jul 21, 2021 08:25:29.439 (PoolThread-30: GlobalPool => NPCEventManagerWebserviceURLPoller) (NetqosEventLog) - (ERROR) - Unable to contact Event Manager - stopping all polling.

Environment

Dx NetOps Performance Management 21.2.1

Cause

The Sso Encryption Decryption Key was updated but not set to the remote value. 

Resolution

This is addressed via defect DE509973 which is resolved starting with the r21.2.2 NetOps release.

To resolve this issue in r21.2.1 without upgrading to a newer current release follow these steps.

NOTE: You will need the Netops Portal MySQL password to enter when prompted.

  1. Gather and compare the SsoEncryptionDecryptionKey value between the netqosportal and em databases.
    1. Connect to the MySql DB using (default path) this command. Enter the password when prompted.
      1. /opt/CA/MySql/bin/mysql -uroot -p
    2. Run the following to show the value for the netqosportal DB:
      1. select PropValue,Priority from netqosportal.performance_center_properties where PropName = 'SsoEncryptionDecryptionKey';
    3. Run the following to show the value for the em DB:
      1. select PropValue,Priority from em.performance_center_properties where PropName = 'SsoEncryptionDecryptionKey';
  2. The values at the highest Priority value shown should match.
    1. If the values do not match for the highest Priority value shown, continue with the remaining steps below to resolve the problem.
    2. IF the values do match for the highest Priority value shown, contact support for additional assistance.
  3. Stop the Event Manager service using the command:
    1. systemctl stop caperfcenter_eventmanager
  4. In the MySql prompt run the following to update the em database SsoEncryptionDecryptionKey value to match the netqosportal database value.
    1. replace into em.performance_center_properties values ('SsoEncryptionDecryptionKey',1,'<keyFrom_netqosportal_DB>','N',UNIX_TIMESTAMP());"
  5. Run the following in the MySql prompt to verify the value is updated and matches in both databases.
    1. Run the following to show the value for the netqosportal DB:
      1. select PropValue,Priority from netqosportal.performance_center_properties where PropName = 'SsoEncryptionDecryptionKey';
    2. Run the following to show the value for the em DB:
      1. select PropValue,Priority from em.performance_center_properties where PropName = 'SsoEncryptionDecryptionKey';
    3. Confirm the highest Priority value from both has a matching value.
  6. Start the Event Manager service using the command:
    1. systemctl start caperfcenter_eventmanager

Confirm the errors are gone from the logs and the Event Manager Data Source is again successfully syncing in the Portal web UI.

This is a sample of a working system. Note the highest Priority value for the netqosportal DB (0) has a value that matches the highest Priority value (1) from the em DB. If these did not match we'd update the em DB Priority value 1 to match the netqosportal DB Priority value 0 value.

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Additional Information

different errors, same fix:

https://knowledge.broadcom.com/external/article/220330/

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