CA IPTAM service fails to start with error java.sql.SQLException: Login failed for user 'sa' incorrect password
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CA IPTAM service fails to start with error java.sql.SQLException: Login failed for user 'sa' incorrect password

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Article ID: 232407

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Updated On:

Products

CA Process Automation Base

Issue/Introduction

ITPAM service failed to start with below error in c2o.log file:
2022-01-13 13:550:28,447 WARN  [org.jboss.resource.connectionmanager.JBossManagedConnectionPool] [6.216.68-8080-1] Throwable while attempting to get a new connection: null
org.jboss.resource.JBossResourceException: Could not create connection; - nested throwable: (java.sql.SQLException: Login failed for user 'sa'.)

Environment

Release : 4.3.X

Component : Process Automation

DB: Microsoft SQL Server

Cause

Password for DB user 'sa' got modified in DB and the same was not updated in ITPAM configuration.

Resolution

Update the encrypted password in OasisConfig.properties file as below:

  1. In the command prompt, navigate to ...\CA\PAM\server\c2o, run: passwordencryption.bat <password in plaintext> 

  2. Incase it throws error as "'C:\Program' is not recognized as an internal or external command,", please refer: https://knowledge.broadcom.com/external/article/204129/process-automation-passwordencryptionba.html 

  3. On successfully execution, it gives encrypted password as shown (starts from 3rd line, ignore the WARN messages):

  4. Copy the encrypted password and update it in the OasisConfig.properties file at below lines(make sure 'sa' user is used for these 3 databases):

         oasis.database.password

         oasis.reporting.database.password

         oasis.runtime.database.password

  5. Save the file and start the service.

In a cluster environment, apply the above steps for all the nodes.