JCS Install Failed creating java jvm.dll
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JCS Install Failed creating java jvm.dll

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Article ID: 232338

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Updated On:

Products

CA Identity Manager CA Identity Service CA Identity Governance

Issue/Introduction

Error installing Java Connector Server (JCS) component. The jcs_service.log and the im_connector_server_install.log will have messages such as the following:

[info]  Starting service...
[error] %1 is not a valid Win32 application.
[error] Failed creating java C:\Program Files\Java\jdk1.8.0_201\jre\bin\client\jvm.dll
[error] %1 is not a valid Win32 application.
[error] ServiceStart returned 1
[error] %1 is not a valid Win32 application.

Environment

IdentitySuite 14.4

Cause

Starting with IdentitySuite 14.4 version the JCS installer package no longer includes an embedded jvm and instead the installer will prompt for the location of java. The installed java should have a \jre\bin\server\jvm.dll but should not have a \jre\bin\client\jvm.dll otherwise the installer will try to use the jvm.dll in the client folder instead of the server folder and the installer will fail.

Resolution

If the java installed on the machine has a \jre\bin\client\jvm.dll then either uninstall and reinstall that java package or point to another java location for the installer and JCS to use which has the \jre\bin\server\jvm.dll but not the \jre\bin\client\jvm.dll also.