Time Slicing Sync Job fails if a custom object with TSV is deleted
search cancel

Time Slicing Sync Job fails if a custom object with TSV is deleted

book

Article ID: 232330

calendar_today

Updated On:

Products

Clarity PPM SaaS Clarity PPM On Premise

Issue/Introduction

The Time Slice Sync Job fails if a custom object with a TSV is deleted.

 

Steps to Reproduce

1) Create a custom object

2) Add 1 or more TSVs

3) create a few instances

4) Run the Time Slice Sync Job - Should be successful (look at the logs)

5) Delete the custom object

6) Run the Time Slice Sync job

 

Expected Results: The Time Slice Sync job is successful

Actual Result: Time Slice Sync Job fails

Environment

Release : 16.0.0

Component : CLARITY TIME SLICING

Cause

This is caused by the customer deleting a custom object that had sql curves on it.  
The logic in the Timeslice Sync Job did not properly clean up once the source table was deleted as the object was deleted. 

Resolution

This is resolved as from Clarity release 16.0.1.

If the issue is encountered in Clarity 16.0 or earlier versions, then contact Technical Support for assistance.

Additional Information

This is caused by the customer deleting a custom object that had sql curves on it.  The logic in the Timeslice Sync Job did not properly clean up once the source table was deleted as the object was deleted. 
 
The missing table (based upon logs) is odf_ca_z_pfm_inv_temp_fin so we just need to delete a row from the odf_nk_fields table.
 
delete from odf_nk_fields where table_name = 'odf_ca_z_pfm_inv_temp_fin'
 
You can also see if other tables are missing by executing the following:

select distinct nk_table_name
  from odf_nk_fields
 where nk_table_name is not null
   and not exists(select 1 from pg_tables where schemaname = 'ppm_ikea' and tablename = nk_table_name)
 
Once these are corrected then the sqlcurves should be created properly.