Automic Agents appear Inactive wrongly in v21 and Job Processing stops
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Automic Agents appear Inactive wrongly in v21 and Job Processing stops

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Article ID: 232287

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Updated On:

Products

CA Automic Workload Automation - Automation Engine

Issue/Introduction

After upgrading to version 21, some Automic Agents from time to time become unreachable from the Automation Engine side and are displayed as "Stopped".

As a result, the Job processing stops causing a lot of production issues.

In AE logs we can see some errors such as:

20211216/103941.771 - U00005002 No hosts could be found for the AgentGroup 'OVBINT_S.SSAS.AZ.HOSTG'.
20211216/104023.002 - U00005011 AgentGroup 'MSC.SQLORA.HOSTG' (host attribute type 'SQL'): the given host attribute type 'WINDOWS' is incorrect.
20211216/104023.007 - U00005011 AgentGroup 'OVBINT_S.INFA_UNX.HOSTG' (host attribute type 'UNIX'): the given host attribute type 'WINDOWS' is incorrect.

Environment

Release : 21.0

Component : AUTOMATION ENGINE

Cause

Defect in Automation Engine side, most likely in the JCP, but issue cannot be reproduced at will for the moment.

Resolution

Workaround:

Restart all Agents seen as Inactive via the Service Manager dialog, agents will be seen as Active by the Automation Engine after that and processing will resume.

Solution:

Update to a fix version listed below or a newer version if available.

Fix version:
Component(s): Automation Engine 

Automation.Engine 21.0.2HF1  - Available
Automation.Engine 21.0.3  - Available

Additional Information

If you experience this issue, please open a case with support and enable the trace tcpip=4 on the JCPs and provide the logs of the Agents affected and the JCP logs and traces.