Environment Promotion - Configuration Import - Conflict
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Environment Promotion - Configuration Import - Conflict

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Article ID: 232207

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Updated On:

Products

CA Service Management - Asset Portfolio Management

Issue/Introduction

Exported configuration information from a Test Environment and performed a Dry Run Import in the New Production Environment. The Dry Run resulted in a conflict with the Contact configuration.

Sample screenshot of the apmp_dryrun_report_XXXX.csv viewed in Excel (entry of concern is in bold)

ContentType:  UiConfiguration
Status:  Conflict
SourceValue:  Contact - Global
TargetValue:  Contact
AdditionalInfo:  The configuration is for Contact

Environment

Release : 17.3

Component :  IT Asset Manager Environment Promotion

Cause

The conflicting configuration on the source system is named “Contact – Global” (which is a global configuration) and there is an OOTB global configuration called “Contact” on the target system. 

Resolution

Rename the source configuration to “Contact” to match the name on the target system, generate a new export, then re-ran the import as a dry run (on the target system) and the conflict did not occur.

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