DefaultAppPool keeps stopping w3wp.exe Exception code 0xc0000374
search cancel

DefaultAppPool keeps stopping w3wp.exe Exception code 0xc0000374

book

Article ID: 232201

calendar_today

Updated On:

Products

CA Network Flow Analysis (NetQos / NFA)

Issue/Introduction

We find that the DefaultAppPool process, under Application Pools in IIS Manager, keeps stopping about once every day and has to be manually restarted. When the pool is in the stopped state, we are unable to run or edit custom reports.

The Event Logs show messages like this:

https://api-broadcom-ca.wolkenservicedesk.com/attachment/get_attachment_content?uniqueFileId=No+vViBJ9xphmm+90YMQTw==

Exception code 0xc0000374

Environment

Release : 21.2

Component : NQRACO - NETQOS RA CONSOLE

Cause

The DefaultAppPool crashes were related to scans from a 3rd-party utility called Nessus

Resolution

 

Found that the DefaultAppPool problems were related to Nessus scans. After stopping the Nessus scans, the Application Pool remained active.

 

Additional Information

See also the following Microsoft article:

https://techcommunity.microsoft.com/t5/iis-support-blog/w3wp-exe-crashes-periodically-error-0xc0000374/ba-p/326869