SpectroSERVER install or upgrade fails with errors
search cancel

SpectroSERVER install or upgrade fails with errors

book

Article ID: 232139

calendar_today

Updated On:

Products

CA Spectrum DX NetOps

Issue/Introduction

The SpectroSERVER Installation or Upgrade fails due to a variety of similar errors.

Two common errors that are seen among the other messages that suggest this is an Anti-Virus software issue are:

  • Error: Unable to interpret installation command
  • cat: .timing: No such file or directory

Spectrum 22.2.x\23.3.x upgrade failing during the pre-installation routine with "** Error:  Unable to interpret installation command"

Other error sample sets and image examples we might see are the following.

** Error: Unable to interpret installation command
Install-Tools/preinst_engine: line 311: cd: /home/spectrum: No such file or directory
Installation Exiting:   <DATE>
cat: .timing: No such file or directory

#################################

#################################

    10 [main] sh 4344 E:\win32app\Spectrum\NT-Tools\SRE\bin\sh.exe: *** fatal error in forked process - WFSO timed out after longjmp
  13174 [main] sh 4344 cygwin_exception::open_stackdumpfile: Dumping stack trace to sh.exe.stackdump

#################################

Environment

All supported DX NetOps Spectrum releases

Cause

Anti-virus software is preventing the installation from completing successfully. Some sample software versions seen causing this. The list is not inclusive, other vendors Anti-Virus software could and would cause this.

  • Carbon Black
  • SentinelOne
  • Trellix End Point Security Agent

Resolution

There are few ways to resolve this. All involve some method of removing the Anti-Virus software from the situation, at least temporarily.

  • Exclude the $SPECROOT directory, and any other Spectrum directory locations, from being touched by the Anti-Virus software and re-run the upgrade.
  • Disable the Anti-Virus software (or exclude SPECROOT) and re-run the upgrade.
  • Uninstall the Anti-Virus software temporarily to re-run the upgrade.

Additional Information

This is a documented requirement. See the Antivirus Software and Data Backup documentation topic in the Fault Monitoring System Requirements documentation section for more information.