Fail to register with task server: Task Server Connection: Task Server: <TaskServer name>, http: 80, https: 443, active: false, installed on NS: false
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Fail to register with task server: Task Server Connection: Task Server: <TaskServer name>, http: 80, https: 443, active: false, installed on NS: false

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Article ID: 232112

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Updated On:

Products

IT Management Suite

Issue/Introduction

Agent fails to receive the tasks because it is not registered to any task server. 

When trying to reset the agent, we see the follow entries in the logs:

 

  • Task Server Connection: Request to NS 'https://<NS>:443/altiris/TaskManagement/CTAgent/GetClientTaskServer.aspx' succeeded.
  • Task Server Connection: There are 1 Task Server available for this computer. 
  • Task Server Connection:  Task Server:  <TaskServer name>, http: 80, https: 443, active: false,  installed on NS: false

Environment

Release: 8.x

Cause

The task server assigned to the agent and site is not reachable or is turned off, and because the Notification Server is not a task server, the agent cannot even register with it.

By default, the Notification Server is also a task server and when an agent cannot register with its own task server, it will register with the notification server instead.

But in some environments like this example, people uninstall the task server from the Notification Server. So, when the task server is not active, the agent cannot register with anything else.  

Resolution

Make sure the task server is active and reachable. 

You can also install the task server on the Notification Server as an alternative option.