Troubleshoot "passphrase not authorized" error
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Troubleshoot "passphrase not authorized" error

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Article ID: 232048

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Updated On:

Products

CA Automic Dollar Universe

Issue/Introduction

Hi support,

We have installed DUAS on new server in cluster mode and we see the DUAS node connected on UVC console. However when I went to design mode, it showed below error

Environment

Release : 6.9

Component : Dollar Universe

Cause

The passphrase is a unique key allocated to node by UVMS when it is registered with UVMS and is maintained by UVMS in DB and at node in the binary file NODE_INSTALL_DIR\data\phrase.key.

From the uvserver.log, we found that there is a node in the network called "NODE" started in a server with a hostname "HOSTNAME" where the passphrase contained in the phrase.key does not match the one contained in the UVMS Database.

|ERROR| request-worker-X | com.orsyp.central.server.AuthentificationStdImpl | Passphrase not authorized for NODE, request coming from:HOSTNAME

Logs snippet sync.log reflects passphrase not been passed to UVMS from node.

----- sending info to UVMS at 12/30/2021 17:28:54 -------> submsg nodeinfo:   node=PICD*****P (utf8) .....   passphrase=

Possible cause of the issue can either be having a cloned node using same passphrase in environment or NODE passphrase is corrupted.

Troubleshooting step below

1: Enable additional logging on Node and UVMS end.

  • UVC -> Administration -> Nodes -> UVMS Server -> Node Settings -> Logging -> set Main Log Level to TRACE and Maximum Size for the Log File(Mbytes) to 200
  •  
  • On problematic node:

1: Stop the node (unistop)

2: Open the values.xml file (i.e. NODE_INSTALL_DIR\data\values.xml )

3: Search for U_LOG_LEVEL and if not present in file please enter <var id="U_LOG_LEVEL">0,IOSYNC,SYNCFILE</var> above element </duas> . It will be like below after change.

....<var id="U_LOG_LEVEL">0,IOSYNC,SYNCFILE</var></duas>​

2: Check the Database Monitoring for below tables

    • UVC -> Administration -> Monitoring and Audit -> Database Monitoring
    • Filter by *node* and look for table UNI_UV_NODES and UNI_UV_NODES_INFO

    • Validate the passphrase and IP allocated with problematic node.

 

Resolution

For this environmental/configuration issue follow below steps

  • Delete the Node from UVC
  • unistop the Node and unims -register -login *** -pwd *** and capture the passphrase
  • Run the unims -update -passphrase *** using the passphrase captured in above step
  • unistart the node
  • Validate if the correct passphrase is updated in the tables.

 

If issue persist, collect UVMS uxserver.log and DUAS universe.log and sync.log and contact support.