Spectrum Integration with CAPM failing after upgrading to DX NetOps Spectrum 21.2.6
search cancel

Spectrum Integration with CAPM failing after upgrading to DX NetOps Spectrum 21.2.6

book

Article ID: 231954

calendar_today

Updated On:

Products

CA Spectrum DX NetOps

Issue/Introduction

Integration with CAPM failing. The following error is seen in the wrapper log file in CAPM:

INFO   | jvm 1    | 2022/01/10 15:27:03 | ERROR | qtp1465931502-20091      | 2022-01-10 15:27:03,621 | com.ca.im.portal.api.services.datasource.DataSourcePoll          
INFO   | jvm 1    | 2022/01/10 15:27:03 |       | Received WebServiceException from version check for data source Spectrum Infrastructure [email protected]  CAUSE=org.apache.cxf.transport.http.HTTPException: HTTP response '403: null' when communicating with http://spm5618:8888/axis2/services/DataSourceWS. MESSAGE=Could not send Message..  Returning DS_COMM_FAILURE result.
INFO   | jvm 1    | 2022/01/10 15:27:03 | ERROR | qtp1465931502-20091      | 2022-01-10 15:27:03,621 | com.ca.im.portal.api.services.datasource.DataSourcePoll     

Environment

Release : DX NetOps Spectrum 21.2.6

Component : CAPM Integration

Cause

Possible root cause is the user used to integrate CAPM with Spectrum is not an Administrator Spectrum user in the DX NetOps Spectrum 21.2.6 database.

Resolution

Starting in DX NetOps Spectrum 21.2.6, the user used to integrate CAPM with Spectrum must be an Administrator Spectrum user.