Error occurred while accessing the database when trying to apply a hotfix
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Error occurred while accessing the database when trying to apply a hotfix

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Article ID: 231838

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Updated On:

Products

CA Privileged Access Manager (PAM)

Issue/Introduction

We recently applied hotfix PAM_LOG4J_44228_45046. When we tried to apply another hotfix, it seemed to proceed initially, but at the point where we would have expected to get a prompt for a reboot, the UI showed message "Error: Error occurred while accessing the database, see the CA PAM log for details." and the hotfix did not get applied. It remains in the list of available patches.

Environment

Release : 3.4.0 - 4.0.1

Cause

The hotfix inadvertently changed permissions on a directory that is used by other hotfixes, such that those hotfixes cannot write file to the directory.

Resolution

On January 18 the PAM_LOG4J_44228_45046 hotfix was updated on the PAM Solutions & Patches page with a version that will not cause this problem. If you had applied the hotfix by that date already, download the PAM_POST_LOG4J_DIR_PERMISSION patch from the same location and apply on top of the old LOG4J hotfix. After that you should be able to apply other hotfixes.

Additional Information

The problem can be observed when trying to do a full backup.