Remedy Integration via NIM broken after 21.2.6 upgrade
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Remedy Integration via NIM broken after 21.2.6 upgrade

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Article ID: 231811

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Updated On:

Products

CA Spectrum DX NetOps

Issue/Introduction

Spectrum 21.2.6 was applied in the environment today. As a result, the Remedy integration via NIM is no longer working. The following messages were seen in the catalina.out file:

Jan 05, 2022 12:26:14.918 (https-jsse-nio-8443-exec-11) (SDIntegration) - SDIntegrationManager - received request: TEST_CONNECTION
Jan 05, 2022 12:26:14.919 (https-jsse-nio-8443-exec-11) (NIMRestClient) - NIMRestClient - connected to https://localhost:8443/ca-nim-sm/api/v2/ with user nimadmin
Jan 05, 2022 12:26:14.922 (https-jsse-nio-8443-exec-11) (NIMRestClient) - NIMRestClient - payload for the NIM {"property":[{"name":"URL","value":"itsmqaapp20.utility.pge.com"},{"name":"Host","value":"itsmqaapp20.utility.pge.com"},{"name":"SFDCLoginEndpoint","value":"itsmqaapp20.utility.pge.com"},{"name":"Username","value":"svcspectrum"},{"name":"EnabledProtocol","value":"http"},{"name":"Protocol","value":"http"},{"name":"ServiceNowClientURL","value":"https://itsmqaweb20.utility.pge.com:8443/arsys"},{"name":"HPSMClientURL","value":"https://itsmqaweb20.utility.pge.com:8443/arsys"},{"name":"ServiceAideClientURL","value":"https://itsmqaweb20.utility.pge.com:8443/arsys"},{"name":"BMCRemedyClientURL","value":"https://itsmqaweb20.utility.pge.com:8443/arsys"},{"name":"SFDCServiceCloudClientURL","value":"https://itsmqaweb20.utility.pge.com:8443/arsys"},{"name":"Port","value":"8888"},{"name":"DateFormat","value":""},{"name":"sendCustomDefault","value":"true"},{"name":"CaseObject","value":""},{"name":"CaseCommentObject","value":""},{"name":"AttachmentObject","value":""}]}for service Desk BMCRemedy
Jan 05, 2022 12:26:14.922 (https-jsse-nio-8443-exec-11) (NIMRestClient) - NIMRestClient - testing connection to NIM web interface
Jan 05, 2022 12:26:14.929 (https-jsse-nio-8443-exec-11) (NIMRestClient) - NIMRestClient - testing web interface successful
Jan 05, 2022 12:26:14.929 (https-jsse-nio-8443-exec-11) (NIMRestClient) - NIMRestClient - updating configurations for BMCRemedy on nim server https://localhost:8443

 

 

 

 

Environment

Release : 21.2.6

Component : Spectrum Integrations

Cause

The log4j-1.2.17.jar was missing from the $SPECROOT/tomcat/webapps/ca-nim-sm/WEB-INF/lib directory. 

Resolution

Ensure that all of the libraries specified in the following documentation are copied over to the $SPECROOT/tomcat/webapps/ca-nim-sm/WEB-INF/lib directory:

https://techdocs.broadcom.com/us/en/ca-enterprise-software/it-operations-management/normalized-integration-management-for-service-management-/3-2/getting-started/readmes-for-the-supported-service-desk-products/ca-nim-sm-bmc-remedy-readme/add-bmc-remedy-sdk-to-ca-nim-sm.html

The log4j-1.2.17.jar was not in the $SPECROOT/tomcat/webapps/ca-nim-sm/WEB-INF/lib  directory. The file was placed in the directory and the customer was able to create a ticket.