Alarm Notifier Is Not Populating Probable Cause or Event Message Field In Alert
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Alarm Notifier Is Not Populating Probable Cause or Event Message Field In Alert

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Article ID: 231752

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Updated On:

Products

CA Spectrum DX NetOps

Issue/Introduction


Email notifications for a specific alarm do not properly populate the pcause. The first line from the Probable Cause file is missing.

 

This specific alarm is using a customized event 0x04cd0337 and the pcause file is present on the SpectroSERVER
      $SPECROOT/custom/Events/CsPCause/Prob04cd0337_en_US


Environment

Release : 21.2 

Component : SpectroSERVER

Cause


Validated that the AlamNotifier saw and read the entire Probable Cause file but still skipped the first line. It seemed to have been
   a formatting issue.



 

 

Resolution


Regenerated / Forced OneClick to update the Probxxxxxxxx_en_US pcause file using the Event Configuration editor.


OneClick ~~> Tools ~~> Utilities ~~> Event Configuration

 

- Make a small update to either 'Symptoms', 'Probable Causes', or Recommended Actions
- Save the Event
- Copy the updated probable cause file from the OneClick server the client was logged into
       $SPECROOT/custom/Events/CsPCause/Probxxxxxxxx_en_US

  Copy to $SPECROOT/custom/Events/CsPCause/ on the SpectroSERVER where the AlarmNotifier(s) are running

- Restart the AlarmNotifier



The Probable Cause now updates correctly in notifications


 

 

Additional Information

This may also happen for the Event Message  $EVENTMSG  

If so, use the same steps as noted above except edit and save the event and then cycle AlarmNotifier.

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