Identity Access Manager Service is not starting as expected and no logs are generated
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Identity Access Manager Service is not starting as expected and no logs are generated

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Article ID: 231662

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Updated On:

Products

Service Virtualization

Issue/Introduction

Having trouble to start IdentityAccessManagerService and not seeing any logs as well with today's timestamp.

bash-4.2$ ls -lrt
total 488
-rw-r--r-- 1 app  app       0 Dec 27 12:58 audit.log
-rw-r--r-- 1 app  app  123191 Dec 27 15:09 server.log.2021-12-27
-rw-r--r-- 1 app  app  130610 Dec 28 08:52 server.log.2021-12-28
-rw-r--r-- 1 app  app  106506 Dec 29 13:05 server.log.2021-12-29
-rw-r--r-- 1 app  app   32652 Dec 30 15:56 server.log.2021-12-30
-rw-r--r-- 1 app  app   49012 Dec 31 23:52 server.log.2021-12-31
-rw-r--r-- 1 app  app   41616 Jan  2 18:30 server.log.2022-01-02
-rw------- 1 root root    182 Jan  3 01:15 server.log
bash-4.2$ pwd
/opt/apps/devtest/IdentityAccessManager/Data/log


bash-4.2$

Environment

Release : 10.7 and newer

Component : Service Virtualization

Cause

Cause:  cannot open ‘server.log’ for reading: Permission denied

Resolution

Looks like the permission on the log folder changed and IAM was not able to write the logs. Given Read/Write permission to the IAM-home/Data/log folder and IAM was able to start successfully.