Masking script does not create any logs when executing through portal
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Masking script does not create any logs when executing through portal

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Article ID: 231643

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Updated On:

Products

CA Test Data Manager (Data Finder / Grid Tools)

Issue/Introduction

I am trying to execute Javelin workflow (masking) via portal.
It created Audit files and logs when masking flow is executed via javelin, however, when the same javelin flow is executed via portal it does create the audit file but does NOT create any masking logs.

Tried running the scripts from user admin and my user but no luck.

Environment

Javelin 4.9.X
TDM Portal 4.9.1.X

Cause

The portal runs under a service account so the default log location will be different from a user running the Javelin process manually

Resolution

When you run the Javelin process manually the FDM masking logs are stored in the user profile running the job.
%AppData%\Roaming\Grid-Tools\FastDataMasker\logs

Example Location for that user:
C:\Users\Administrator\AppData\Roaming\Grid-Tools\FastDataMasker\logs

When the same Javelin flow is run from the portal is being run as the Service account on the service.
By default, this is the localsystem account.
The default location for the localsystem account profile is:
C:\Windows\System32\config\systemprofile 

the full path to the log files would be:
C:\Windows\System32\config\systemprofile\Roaming\Grid-Tools\FastDataMasker\logs


Note: If the TDM Portal is running as an LDAP User account then the path will be to that user's profile directory.