DB2 Licensing connection error for Datamaker and Javelin
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DB2 Licensing connection error for Datamaker and Javelin

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Article ID: 231639

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Updated On:

Products

CA Test Data Manager (Data Finder / Grid Tools)

Issue/Introduction

When connecting to the DB2 database in the Datamaker or Javelin it is giving error as below:

Cannot connect using supplied values.

Connection: Data Source
Profile: CIX_QV
odbc: -1598
SQLSTATE = 42968
[IBM][CLI Driver] SQL1598N  An attempt to connect to the database server failed because of a licensing problem.  SQLSTATE=42968

But same works in TDM portal connection profiles without giving an error.

 

 

Environment

Release : 4.9.1

Component : Datamaker and Javelin

Cause

This issue is caused due to way Datamaker and Javelin connect with a DB2 on z/OS. They need a properly licensed version of DB2 connect matching the DB2 driver in use.

The DB2 driver was upgraded but the corresponding license was not created and registered correctly.

Resolution

After DB2 client drivers are upgraded, its required to get a new license generated for that specific Driver JAR. 

Refer below link and get in touch with your DBA to get the license updated.

- https://www.ibm.com/support/pages/sql1598n-error-connecting-mainframe-db2-ibm-data-server-driver-even-though-db2-connect-license-file-exists-license-directory-install-path

- https://www.toolbox.com/tech/data-management/question/sql1598n-an-attempt-to-connect-to-the-database-server-failed-because-of-a-licensing-problem-040215/

Also register the DB2 connect with generated license file.

Below are the DB2 commands used.

To check DB2 version and license info
>>db2licm -l

To remove any existing license
>>db2licm -r db2consv

To register the product with correct license(.lic) file
>>db2licm -a “License file path\licensefile.lic”