Alarms viewer portlet displays blank page after upgraded to 20.4
search cancel

Alarms viewer portlet displays blank page after upgraded to 20.4

book

Article ID: 231563

calendar_today

Updated On:

Products

DX Unified Infrastructure Management (Nimsoft / UIM) CA Unified Infrastructure Management On-Premise (Nimsoft / UIM)

Issue/Introduction

Alarms page in (OC) Operator Console is blank after updating to 20.4.

or

Environment

Release : 20.4

Component : Operator Console, Alarm Viewer

Cause

This can relate to unrelatable data in the UMPALARMVIEWERINFO table, either in the Columns or Filters fields or both. This table holds user-specific customizations of the alarm viewer window. The most immediate resolution to this would be to make an export of the table for reference, and delete the specific user entry that is having an issue or all records if it is global to all users.

Resolution

- Export a copy of the row data from the following table:

select * from UMPALARMVIEWERINFO

- Execute the following query to empty the table:

delete from UMPALARMVIEWERINFO where OwnerName = '<user>'

         or (if the problem is global to all users)

delete from UMPALARMVIEWERINFO

- Logout and back into the Operator Console

- Check the alarm viewer once again

Additional Information

Note: If you are using Oracle as the UIM backend database then you should issue the query as follows:

delete from UMPALARMVIEWERINFO where OwnerName = '<user>';
commit;

         or (if the problem is global to all users)

delete from UMPALARMVIEWERINFO;
commit;