Record mismatch for find and reserve
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Record mismatch for find and reserve

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Article ID: 231476

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Updated On:

Products

CA Test Data Manager (Data Finder / Grid Tools)

Issue/Introduction

There is a record count mismatch between SQL developer and find/reserve model.

Environment

Release : 4.9.1

Component :

Cause

If the data source/data set for the Find & Reserve Data Model is large, there is a possibility that the Data Prefetch can get out of sync with the actual data source. There are numerous reasons this can happen. Such as, the on demand Data Prefetch request takes too long to complete, and the request times out before the sync happens, the data set is so large that the periodic Data Prefetch request never completes before the next Data Prefetch job runs, etc.

Resolution

When using large data sets for your Find & Reserve job, Broadcom recommends disabling Data Prefetch, by setting the Data Prefetch option to Off. However, this option cannot be changed without recreating Find & reserve Data model.


For more information regarding Find & Reserve and Data Prefetch, see https://techdocs.broadcom.com/us/en/ca-enterprise-software/devops/test-data-management/4-9/provisioning-test-data/configure-test-data-reservation-service/configure-dynamic-test-data-reservation-service/data-prefetch.html