APM - Connection failure to WebView after the upgrade
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APM - Connection failure to WebView after the upgrade

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Article ID: 231428

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Updated On:

Products

CA Application Performance Management (APM / Wily / Introscope)

Issue/Introduction

Failed to connect to WebView after the upgrade from APM 10.5  to APM 10.7

 

Browser Message:

<snip>

This site can’t provide a secure connection

apmwly-stg.transunion.com uses an unsupported protocol.

ERR_SSL_VERSION_OR_CIPHER_MISMATCH
<end snip>
 
 
IntroscopeWebview Log: 

 [WARN] [org.mortbay.log] EXCEPTION 
javax.net.ssl.SSLHandshakeException: no cipher suites in common

MOM IntroscopeEnterpriseManager.log

 [INFO] [RemoteHttpCallServiceExecutor-9] [Manager.AppMap.RemoteHttp] SSLHandshakeException: Received fatal alert: handshake_failure

 

Cause

The problem seems to be caused by a mismatch between the keystores and the  truststores.

Resolution

Copied the cacerts file from a backup and updated the alias in the files em-jetty-config.xml and webview-jetty-config.xml to be the same as it was in 10.5. 

Now everything looks to be running properly.